Get in touch
Back
Maintenance

Deployment of our new Website

Completed 17 Jun at 03:00am CEST.

Quiz Coach Website Learning by Quiz Coach
Completed

Posted 17 Jun at 03:00am CEST.
Started

We have a new website that is served on quiz-coach.com.
Our old website and the learning platform, that were served on that same address, are now available on learning.quiz-coach.com

Posted 16 Jun at 09:30pm CEST.