Get in touch
Back
Maintenance

Learning updates

Completed 21 Jan at 11:59pm CET.

Learning by Quiz Coach
Completed

Maintenance completed

Posted 21 Jan at 11:59pm CET.
Started

Our services will be not available due to a planned system update.

Sorry for the inconvenience.

Objectives:
- Partner portal
- Training invitation mail upadtes
- Smart link updates
- Training registration feature
....

Posted 21 Jan at 11:00pm CET.